> Anyway, thanks for the report.  It shouldn't be hard to track down.

Well the error comes from: c:/langs/ruby/lib/ruby/1.8/open-uri.rb:544:in
`proxy_open'.
Looking around there, there's no HTTP::Proxy to be found in the area. I
guess the wrong version got packaged in the gem.