Noticed this while I was playing around trying to uninstall my older 
version of rake with rubygems:

Attempting to uninstall gem 'rake'
Select RubyGem to uninstall:
  1. rake-0.3.1
  2. rake-0.3.2
  3. All versions
 > 3
/home/cec/s/c/cc1/usr/lib/ruby/site_ruby/1.8/rubygems/installer.rb:282:in 
`uninstall': undefined method `remove_all' for 
#<Gem::Uninstaller:0x4021664c @version="> 0.0.0", @gem="rake"> 
(NoMethodError)
         from /home/cec/s/c/cc1/usr/bin/gem:445:in `uninstall'
         from /home/cec/s/c/cc1/usr/bin/gem:117:in `run'
         from /home/cec/s/c/cc1/usr/bin/gem:694

Should bug reports like this go to c.l.r. or to the rubyforge bug 
reports page or the wiki or something?

Charles Comstock