Gregory Millam wrote:
> That button () construct doesn't quite strike me as correct -
> and could probably be done better
> 
> button "buttonname" {
>   on_click { ... }
> }
> 
> Make it more generic across container-type objects. OTOH,
> Buttons are rarely used as such a container. *ponder ponder
> ponder* ...
> 
> Maybe 
>   button_onclick "buttonname" {
>     ...
>   }

Since the only thing that can happen to a button is that someone
clicks it it might be more concise to leave the onclick out.
Something like:

button "name" { 
  ...
}

BTW, this is a great line of thinking. I have often craved a more
ruby-esque GUI API. This could finally make GUI programming fun.


Asim