Hi all,

I tried to 'build' Why's poignant guide to Ruby on my machine, but got
this message:

     C:\tmp\wpgtr>C:\tmp\wpgtr\poignant.rb .
     c:/ruby/lib/ruby/1.8/yaml.rb:39:in `load': parse error on line 
1160,
     col 4: `    - !^sidebar' (ArgumentError)
             from c:/ruby/lib/ruby/1.8/yaml.rb:39:in `load'
             from C:/tmp/wpgtr/poignant.rb:12:in `load'
             from C:/tmp/wpgtr/poignant.rb:78

The Ruby version is this:

     C:\tmp\wpgtr>ruby -v
     ruby 1.8.0 (2003-08-04) [i386-mswin32]

and I installed the recent redcloth 2.0.3.
I'm running into the very same error, when running on Linux (same 
redcloth version but Ruby 1.8.1).

Now ... what? The YAML line looks like all the other ones starting with
"    - !^sidebar"...

Any ideas? Has anybody else ever tried to run "poignant.rb", except of 
course Why?

Happy rubying

Stephan