I have this problem with ruby/sdl on MacOS X:

emac:~/.tmp/rubysdl-0.9.2 jdrake$ ruby
require 'sdl'
objc: failed objc_getClass(NSObject) for SDL_QuartzWindow->isa->isa
objc: please link appropriate classes in your program
Trace/BPT trap


I have tried putting some print statements in the module's init but
none seem to be printed.

I am on MacOS X 10.3.3, running fink - installed everything through
it: ruby 1.8.0, sdl 1.2.7, and associated libraries.

ruby/sdl and sge was manually compiled in.


Any help would be appreciated. Please reply to group because email
address is just a spam trap now.

- Jeffrey Drake
wackysteak A T. mac D OT com