Richard wrote:
> I really hope nobody gets offended by my plea for some mercy.
> 
> I've looked and I've tried... and frankly I'm a bit dissapointed at why
> there's no 'support' for a Windows 2000/XP install of MySQL
> (mysql-4.0.18-win-noinstall.zip), and mysql-ruby (mysql-ruby-2.4.4.tar.gz).
> 
> Almost all of the tutorials I've read use linux paths, or assume a
> knowledge of the command 'make'.
> 
> I really don't know what I'm doing (I've used the 'make' command maybe
> 40 times - 15 of which were to try and get mysql-ruby working).
> 
> Does anyone have a _really_ user friendly way to get ruby-dbi
> (ruby-dbi-all-0.0.21.tar.gz) working with the MySQL and mysql-ruby
> mentioned using ruby (1.8.1 pragProg windows installer)?
> 
> I'm looking to create my own 'phpMyAdmin' for ruby, but that would mean
> getting a connection over tcp/ip from ruby to mysql (I've read that
> proxy.rb needs to run for the tcp/ip part - I'm just not there yet).
> 
> I would love any help or pointers.
> 
> All of the emails I've read involve versions of ruby that are not 1.8.1.
> 
> Thanks in advance for any helpful replies!
> 
> -Rich
> 
> 
  Try ruby-mysql instead of mysql-ruby.  Its written in pure ruby so 
deosn't need to be compiled.

http://raa.ruby-lang.org/list.rhtml?name=ruby-mysql