>
>I don't think that's what the OP wanted.  This seems to be more
>appropriate

Indeed.  remove_method and undef_method is what I want.

Is there a particular reason there's no remove_instance_variable to match all
the other remove_ methods of Module?