Hi,

At Fri, 26 Mar 2004 12:11:54 +0900,
Ruby Ruby wrote in [ruby-talk:95888]:
> compiling digest/rmd160
> 
> /installfs/ruby181/ruby-1.8.1/ext/digest/rmd160/extconf.rb:6: undefined method `-@' for "-g -O2":String (NoMethodError)

You miss to apply the patch.

# BTW, why do you put empty lines per each lines?


This is the whole ext/digest/rmd160/extconf.rb.

# $RoughId: extconf.rb,v 1.3 2001/08/14 19:54:51 knu Exp $ # $Id: extconf.rb,v 1.6 2004/01/21 07:01:31 nobu Exp $ require "mkmf" $CPPFLAGS << " -DNDEBUG -DHAVE_CONFIG_H -I#{File.dirname(__FILE__)}/.." $objs = [ "rmd160init.#{$OBJEXT}" ] dir_config("openssl") if !with_config("bundled-rmd160") && have_library("crypto") && have_header("openssl/ripemd.h") $objs << "rmd160ossl.#{$OBJEXT}" else $objs << "rmd160.#{$OBJEXT}" << "rmd160hl.#{$OBJEXT}" end have_header("sys/cdefs.h") have_header("inttypes.h") have_header("unistd.h") $preload = %w[digest] create_makefile("digest/rmd160")
-- Nobu Nakada