On Mar 25, 2004, at 3:08 AM, Vivek Nallur wrote:

> Hi
>
> I'd gone over to the wiki on rubyforge and was experimenting with
> RubyGems. However, I can't seem to get it working right. Atleast,
> progressbar doesn't seem to install properly.
>
> When I do:
>
> Prompt> gem --remote-install progressbar
>
> It comes back with:
> Successfully installed progressbar version 0.0.3
>
> However,
> Prompt> gem --verify progressbar
>
> results in:
>
> progressbar is invalid
>
> If it helps, "gem --alien" resulted in the following output:
>
> Checking gem database for inconsistencies
> /usr/local/lib/ruby/gems/1.8/sources-0.0.1
> /usr/local/lib/ruby/gems/1.8/progressbar-0.0.3
> sources-0.0.1 is error-free
>
> progressbar-0.0.3 has 1 problems
>         /usr/local/lib/ruby/gems/1.8/cache/progressbar-0.0.3.gem:
>         Unmanaged files in gem: ["docs", "sample"]
>
>
> I'm using ruby 1.8.0 (2003-07-31) [i686-linux]

FWIW, I'm getting the same errors:

% gem --verify progressbar
progressbar is invalid
% gem --alien
Checking gem database for inconsistencies
/usr/local/lib/ruby/gems/1.9/sources-0.0.1
/usr/local/lib/ruby/gems/1.9/RedCloth-2.0.2
/usr/local/lib/ruby/gems/1.9/progressbar-0.0.3
sources-0.0.1 is error-free

progressbar-0.0.3 has 1 problems
   /usr/local/lib/ruby/gems/1.9/cache/progressbar-0.0.3.gem:
   Unmanaged files in gem: ["sample", "docs"]


RedCloth-2.0.2 has 1 problems
   /usr/local/lib/ruby/gems/1.9/cache/RedCloth-2.0.2.gem:
   Unmanaged files in gem: ["tests", "docs"]


% gem --verify RedCloth
RedCloth is invalid

--Mark