Gavin Sinclair <gsinclair / soyabean.com.au> writes:

> On Thursday, March 25, 2004, 10:49:27 PM, Jim wrote:
[snip]
> > It looks like Paul is having a different problem than I am. BTW, I'm using Mac
> > OS X.
> 
> ~>> gem --remote-list
> > gem: invalid option: --remote-list
> 
> Do you have the CVS version or the released version?

The released version.

>  What does 'gem --help' say?

~> gem --help
Usage: gem [options]
    -b, --build=GEMSPEC              Build a gem file from spec
....

>  What does 'gem --list' do?

~> gem --list
rake-0.3.1
sources-0.0.1
log4r-1.0.5
RedCloth-2.0.2
lafcadio-0.3.4

> NOTE: everybosy who is currently using RubyGems please take a quick
> look at
> 
>   http://rubygems.rubyforge.org/wiki/wiki.pl?NewVsOldInterface
> 
> It will clear up some of this confusion.

It certainly does. The released version doesn't support '--remote --list',
which explains why it didn't work for me.

Thanks for your help, Gavin.

Jim
-- 
Jim Menard, jimm / io.com, http://www.io.com/~jimm/
"Abraham Lincoln didn't die in vain. He died in Washington, D.C."
    -- Firesign Theatre