Hello all,

This is a summary of ruby-dev ML in these days.


[ruby-dev:23201] [Oniguruma] Version 2.2.5

  Kosako released Oniguruma Version 2.2.5. It has been already
  imported into the Ruby CVS. And also you can get it from
  Kosako's page:
    http://www.geocities.jp/kosako1/oniguruma/

[ruby-dev:23212] warning: fork terminates thread

  Tanaka Akira proposed to suppress "fork terminates thread"
  warnings on using folk with thread as follows:

    % ruby -ve 'Thread.new { sleep }; pid = fork {}; Process.wait pid'
    ruby 1.9.0 (2004-03-22) [i686-linux]
    -e:1: warning: fork terminates thread at -e:1

  Rationale for the proposal is:

    * If the warning is for chang of specification of fork in
      Ruby 1.8, it should be suppressed on Ruby 1.9.

    * fork must be used when system and popen are inadequant.
      In such a case, the warning is unsolicited.

    * Even if the user doesn't use thread explicitly, some libraries
      such like timeout use thread implicitly.

  Matz agreed to do it.


Regards,

TAKAHASHI 'Maki' Masayoshi     E-mail: maki / rubycolor.org