"Jim Weirich" <jim / weirichhouse.org> writes:

> Paul Vudmaska said:
> > I'm running WinXP 1.8 ruby and get this error.
> >
> > C:\ruby\gems\rubygems-0.2.0>gem --remote -list
> 
> Did you get the CVS version of RubyGems?  The latest CVS version has been
> refactored to make the --remote/--local destinction orthoganal to the
> other options.  So you would need to say ...
> 
>    gem --remote --list
> 
> (Notice the *two* dashes on the list option).
> 
> Give that a try.

spoon> gem --remote --list
/usr/local/lib/ruby/site_ruby/1.9/rubygems/remote_installer.rb:78:in `find_latest_valid_package_in_caches': Could not find --list > 0.0.0 (RuntimeError)
        from /usr/local/lib/ruby/site_ruby/1.9/rubygems/remote_installer.rb:15:in `install'
        from /usr/local/bin/gem:74

This is with a new RubyGems installation.

Jim
-- 
Jim Menard, jimm / io.com, http://www.io.com/~jimm/
"Any sufficiently complicated C or Fortran program contains an ad hoc
informally-specified bug-ridden slow implementation of half of Common Lisp."
    -- Greenspun's Tenth Rule of Programming