On Friday 05 Mar 2004 16:04, Brett Williams wrote:
> We recently upgraded to GCC 3.3.3 and now we can no longer compile ruby
> due to its use of some obsoleted constructs.

Ruby successfully compiled the latest stable snapshot with 3.3.3, so perhaps 
you should move to that until the next release is made.