angus <angus / quovadis.com.ar> writes:
>A trivial readability improvement:

>Instead of

>        for entry in @@romanlist
>            sym, num = entry[0], entry[1]
>I think it's better to write
>        for sym, num in @@romanlist

Or even

        @@romanlist.each do
            |sym, num|
            ...
        end

I tend to forget that Ruby even *has* a "for" keyword. :)

-Mark