Mark Hubbart wrote:
> 
> On Feb 19, 2004, at 11:50 PM, Gavri Savio Fernandez wrote:
>> Okay, what i'm driving at is this: Naming one method 'warn' (A verb. I 
>> like that) and another 'warning' (A noun. Don't like it much) is quite 
>> confusing :(
>> There doesn't seem to be any clue in their names to differentiate 
>> their functionality from each other.

Agreed. Clear in my mind, but that probably says more about my mind
than about the syntax. :)

> 
> How about:
> warn "Server timed out. retrying."
> warn! "That number seemed a bit high... Possible error."
> 
> This would keep the old behavior for warn(), but add a new function 
> warn!(), which would be used for more serious warnings where you want to 
> include a traceback.

I like Mark's idea better than mine.

Hal