Hi,

  In mail "ruby-dev summary 22625-22687"
    "K.Sasada" <ko1 / namikilab.tuat.ac.jp> wrote:

> [ruby-dev:22642] optparse default options
>   Minero Aoki asked if the default definition of "--help" option of
>   OptionParser would be overspec. (This issue is still open.)

My intent is not on "--help", but "--version".

  ~ % cat test.rb
  require 'optparse'
  parser = OptionParser.new
  parser.parse!

  ~ % ruby-1.8.1 test.rb --version
  test 1.8.1
  ~ %

This "1.8.1" is derived from "VERSION" constant.
OptionParser sees the definition of "--version",
next "Version", then "VERSION".


Regards,
Minero Aoki