On Sat, Jan 24, 2004 at 06:31:08AM +0900, Daniel Carrera wrote:
> Hi all,
> 
> IIRC, JRuby is a Java implementation of Ruby 1.6.  The Racc web page says that 
> it requires either Ruby 1.8 or the -E flag.

That's because parsers generated with racc require some runtime
support... If you installed racc (or are using 1.8) you have that already.
Otherwise the -E flag makes a standalone parser.

> Does this mean that I can reasonably expect to use Racc to create a BibTeX 
> parser that would be run using JRuby?

You could test the parsers in sample/; they should normally run ok.

-- 
 _           _                             
| |__   __ _| |_ ___ _ __ ___   __ _ _ __  
| '_ \ / _` | __/ __| '_ ` _ \ / _` | '_ \ 
| |_) | (_| | |_\__ \ | | | | | (_| | | | |
|_.__/ \__,_|\__|___/_| |_| |_|\__,_|_| |_|
	Running Debian GNU/Linux Sid (unstable)
batsman dot geo at yahoo dot com

And Bruce is effectively building BruceIX
	-- Alan Cox