Hi everybody, I try to run mod-Interbase0.03 with Firebird1.0.2.908, on Linux 
Mandrake 9.1.
I installed ruby 1.8.0 in /usr/src and interbase-0.03 in the same directory. 
Firebird is in /opt/interbase! The compiling phase seems good!

Now I create a database in /home/joe/test.gdb and I try to test with simple 
script (prova2.rb):
-------------------------
#!/usr/local/bin/ruby
require "interbase"
conn = InterBase::connect('localhost:/home/joe/test.gdb, 'sysdba','masterkey') 
conn.execute('select * from my_table')
conn.commit
conn.close
----------------------------

and receive from shell:

[root@hostnbook joe]# ruby prova2.rb
prova2.rb:4:in `execute': An error was found in the application program input 
parameters for the SQL statement. (InterBase::Error)
        from prova2.rb:4

I can't understand the mistake! My SQL seems good. Can you help me? Is there 
anybody using mod-Interbase0.03 with Firebird Database?
Greetings.
Giuseppe Massa