"Pe?a, Botp" <botp / delmonte-phil.com> wrote in message...

<snip>

> F:\usr\bin>ruby -vw test3.rb
> ruby 1.8.1 (2003-12-25) [i386-mswin32]

<snip>

> note: win2k sp 4

<snip>

Botp,

After reproducing the crash on both SP3 and SP4, I realized that the
likely difference was that you're using Ruby 1.8.1 and I'm using Ruby
1.8.0.  I just upgraded to Ruby 1.8.1 and confirmed that the example
exits without the crash!  Well, I wonder what the root cause was?

Cheers!
Yonatan