Hi,

In message "Inconsistent value of uninitialized variable"
    on 03/12/29, Gavin Sinclair <gsinclair / soyabean.com.au> writes:

|However, this one does not (again, free of all context):
|
|  x = x
|  x         # nil
|
|This, to me, is inconsistent and undesirable behaviour.  I would
|prefer this:
|
|  x = x     # NameError: undefined local variable or method `x' ...
|
|I haven't given it much thought, but the existing behaviour cost me 15
|minutes debugging, and I:
| * don't see a benefit of the existing behaviour;
| * do see a benefit (consistency) of changing the behaviour.
|
|Any comments?

It's just application of the simple rule "local variables are defined
when they first appear in the left side of assignment", and was much
easier to implement.

I wouldn't disagree with you (but not really motivated enough to fix
by myself).

							matz.