I also have tried installing dbdbd and I am running ruby 1.8.0
Using insert I get the following
/usr/lib/ruby/site_ruby/1.8/dbdbd.rb:113: warning: Object#type is deprecated; 
use Object#class

I also get undefined methods 'fields'

On Fri, 26 Dec 2003 16:04:29 +0000, Tim Hunter wrote:

> On Fri, 26 Dec 2003 08:57:06 -0700, Joseph Paish wrote:
> 
>> has anyone successfully installed dbdbd?  this program has just the
>> right level of simplicity and power for what i want to do (manage a
>> small to medium-sized flat file database).
>> 
>> i have downloaded and unzipped it onto my single-user machine and when i
>> try and install it using "ruby install.rb" as root (as per the
>> documentation included with the program) i get the following error
>> message :
>> 
>> install.rb:10: undefined method '+' for nil (Name Error)
>> 
>> line 10 in install.rb looks like this : dest =
>> Config::CONFIG["sitelibdir"] + File::SEPARATOR + source
>> 
>> am i missing a library i need in order to install this program?  or is
>> it something else that is so obvious that i'm not seeing it?
>> 
>> thanks
>> 
>> joe
>> 
>> ps. i am running ruby 1.6.2 on linux.
> 
> 1.6.2? Really? It's possible that such an old version of Ruby didn't
> define the 'sitelibdir' entry. I'd try upgrading to 1.8.1 and then
> installing dbdbd.

-- 
Ed Redman
redman / accesswave.ca
Scouts Canada
Commissioner Forest Lakes