> Maybe this is the source of my latest problems (see the other thread 
> on this).
> And thanks for the info on sudo. I think you are right about ruby 1.8
> for OS X--I'll post here if I find it, and I will install the complete
> 1.8 version and see what happens.

Rich Kilmer has a very good step-by-step guide on how to retrieve the 
latest cvs version of  Ruby and compile it. Even though it's focused on 
10.3, it should apply just fine on 10.2.x as well.

http://richkilmer.blogs.com/ether/2003/10/building_ruby_1.html

cheers
//samuel