Hi,
    After removing those lib*.* files in my environment ( which were found
in c:\windows\system32) and reinstall new gtk+-2.2.4 from dropline, it
worked finally.
     However, as it was mentioned in the document ( I noticed somewhere, but
cann't recall exactly ), Gtk currently cann't support Chinese fonts ( I'm
using Big-5 encoding):
i.e. when running the test GUI samples, warnings always appeared:
    WARNING **: [Invalid UTF-8] Couldn't load font "???? 9" falling back to
"Sans 9"
and then, the GUI was displayed without any fonts shown..... another oddity.

Anyway, thanks a lot for your patient instructions.
I hope someday it will work in my system.

Best regards,

Tk Kuo

"Masao Mutoh" <mutoh / highway.ne.jp> in
news:20031209151649.39fc21d3.mutoh / highway.ne.jp wrote:
> So, I suspect your ruby found an old libdk-win32-2.0-0.dll(version 2.0.x)
first.
>
> Try:
>
> 1. Remove *ALL* libgdk-.......dll in your environment once.
> 2. Remove *ALL* libgtk-...., libpango...., libgdkpixbuf..., libgobject...
>    libatk..., libglib...., too.
> 3. Install new gtk+-2.2.4 from dropline.
>    http://www.dropline.net/gtk/
>
> P.S.
> Read our Install Guide again. And check the PATH variable and others.
>   http://ruby-gnome2.sourceforge.jp/hiki.cgi?Install+Guide+for+Windows
>
> -- 
> :% Masao Mutoh<mutoh / highway.ne.jp>
>
>