On Tue, 25 Nov 2003, Florian Gross wrote:

> Date: Tue, 25 Nov 2003 08:54:02 +0900
> From: Florian Gross <flgr / ccan.de>
> Newsgroups: comp.lang.ruby
> Subject: Re: raise unless RUBY_VERSION[%r/^\s*\d+\.\d+/o].to_f >= 1.8
> 
> Moin!
> 
> Ara.T.Howard wrote:
> 
> > any better methods of require a specific version/set of versions?
> 
> What about RUBY_VERSION >= "1.8.0"?
> 
> Regards,
> Florian Gross

i thought about this for a while and came up with a good reason not to do this
- but it currently eludes me!

unless someone can think of a reason not to - i'll take it!

;-)


-a
-- 

ATTN: please update your address books with address below!

===============================================================================
| EMAIL   :: Ara [dot] T [dot] Howard [at] noaa [dot] gov
| PHONE   :: 303.497.6469
| ADDRESS :: E/GC2 325 Broadway, Boulder, CO 80305-3328
| STP     :: http://www.ngdc.noaa.gov/stp/
| NGDC    :: http://www.ngdc.noaa.gov/
| NESDIS  :: http://www.nesdis.noaa.gov/
| NOAA    :: http://www.noaa.gov/
| US DOC  :: http://www.commerce.gov/
|
| The difference between art and science is that science is what we
| understand well enough to explain to a computer.  
| Art is everything else.  
|   -- Donald Knuth, "Discover"
|
| /bin/sh -c 'for l in ruby perl;do $l -e "print \"\x3a\x2d\x29\x0a\"";done' 
===============================================================================