Hidetoshi NAGAI wrote:

> If get none... Sorry. The library is not tested on ruby 1.8.x.
> Please wait for a new library which supports ruby 1.8.x.

I get none. But I am happy to hear that this project is not dead... :)

> Or create new Tix.rb for Tix8.1 based on the sample Tix-for-TkPackage.rb
> which generated for Tix4.1.
[...]
> Now, you'll be able to use Tix library by 'require "Tix.rb"'.
> The generated Tix.rb is a result of automatic estimation.
> So, it is NOT perfect. It's only a template for better definitions.

This is what I did. I use TixCombobox from it, and it works for me.

> > PS: Running mk_tkextlib.rb I have realized that the tcltklib+exception
> > problem
> > (http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=200309141511.h8EFBYd13608%40moulon.inra.fr)
> > still exists...
> 
> Please try the newest CVS version with the '--with-pthread-ext' configure
> option.

Thanks, but I am too lazy, I still waiting for the debianized version...
;-)

Bye:
Ferenc