I have mod_ruby installed but am running it under cgi at the moment -- 
I want to run under mod_ruby eventually, but make it work, then work 
right, then work fast =)

Completely disabling mod_ruby makes no change

Forcing it to run under mod_ruby gives me a security error:

./FileEntries.rb:85:in `stat': Insecure operation - stat (SecurityError)
         from ./FileEntries.rb:85:in `traverse'
         from ./FileEntries.rb:84:in `each'
         from ./FileEntries.rb:84:in `traverse'
         from ./FileEntries.rb:52:in `initialize'
         from ./RubLog.rb:81:in `new'
         from ./RubLog.rb:81:in `process_request'
         from ./RubLog.rb:66:in `initialize'
         from /home/mccallister/www/rublog-0.8.0/rublog.rb:33:in `new'
         from /home/mccallister/www/rublog-0.8.0/rublog.rb:33
         from /usr/local/lib/ruby/1.8/apache/ruby-run.rb:70:in `load'
         from /usr/local/lib/ruby/1.8/apache/ruby-run.rb:70:in `handler'

Running it as a normal cgi I get the previously mentioned error. The 
"can't modify frozen string (TypeError)" is why I thought that maybe 
something changed between 1.6 and 1.8.

httpd cgi config is pretty vanilla:

LoadModule cgi_module modules/mod_cgi.so
AddHandler cgi-script .cgi

Aside from that it is httpd 2.0.48 prefork and 1.8.0 release with 
nothing extra aside from eruby installed.

-Brian

On Thursday, October 30, 2003, at 12:00 PM, Chad Fowler wrote:

> On Fri, 31 Oct 2003, Brian McCallister wrote:
>
> # As Dave doesn't have a -users list for Rublog I am asking here, sorry
> # if it is offtopic...
> #
> # I am having a bear of a time getting rublog to work under 1.8.0 I get
> # errors along the lines of:
> #
>
> No problems here under 1.8.0.  Have you tried it with Webrick?  I'd be
> interested to know if it works there.  What's your web server config?
> mod_ruby?
>
> Chad
>
>
>



-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (Darwin)

iD8DBQE/oViTaOuMdvjqKWcRAtlpAJ44TmxkqGKRESxDe7JSfP64TX80vQCdH+g/
2+bXBrTZof26TZoPLmCm88I=
=psQR
-----END PGP SIGNATURE-----