"Magnus Engströí" <magnus / aoeu.info> wrote in message
news:20031004152224.GA22511 / capsaicin.machnus.net...
>I tried to compile kahakai (a window manager with ruby support) on a
Slackware 9 box, >with --enable-ruby.

>It stops with some error like
>"swig_wrapper_ruby.cc:983: invalid conversion from `const KaScreen*' to `
KaScreen*'"

>Have tried swig 1.3.16 and .17, as well as latest CVS, none working.
>Anyone here that successfully compiled with ruby support? Which swig did
>you use?

I used CVS swig to compile kahakai from kahakai CVS a few days before the
0.5 release.  Kahakai is rapidly evolving (that is to say, unstable).  In
order to successfully compile with Ruby support, I had to use a fully
upgraded Debian SID box (as well as CVS kahakai and CVS swig).

The best way to get help with this is to get on irc.freenode.net, channel
#kahakai.  They are very helpful--they can at least tell you what bleeding
edge tools they are currently using.

Having a window manager that is scriptable in Ruby sounds like a great idea.
But the 0.5 release dropped my must-have merged windows feature, so I've
stopped following kahakai :(

Brett Williams