On Tue, 2003-09-23 at 14:20, dblack / superlink.net wrote:
> >
> > After some head-scratching, it appears that I need the "un" library, as
> > the Makefile is doing:
> >   ruby -run -e "..."

> un.rb comes with 1.8.0 (look in the lib subdirectory of the source).
> Is it possible that your Makefile is somehow hitting an older version
> of Ruby?

Yep, that was it exactly.
  /usr/local/bin/ruby -v --> 1.8.0
  /usr/bin/ruby -v --> 1.6.8

Thanks very much to you & Hiroshi for the quick reply.

I now have a GTK window up !! (ok, it's empty, but it's a start :-)

PS: it isn't mentioned in the Ruby reference at    
   http://www.rubycentral.com/ref/
Shouldn't it be in the "modules" section?