Hi,

Robert Feldt <feldt / ce.chalmers.se> writes:

> Which Ruby version is the working one above? It says its also
> a cygwin ruby. Sorry I don't understand what you mean
> here.

Sorry for confusing you.
I mean:

% /usr/local/bin/ruby -v
ruby 1.8.0 (2003-09-08) [i386-cygwin]
% /usr/bin/ruby -v      
ruby 1.8.0 (2003-08-04) [i386-cygwin]


> I rebuilt from cvs sources but still get the same problem:
> 
> $ ruby -v
> ruby 1.8.0 (2003-09-08) [i386-cygwin]
> 
> $ ruby test.rb
> Hello!
> 1
> (eval):5: [BUG] Segmentation fault
> ruby 1.8.0 (2003-09-08) [i386-cygwin]

Hmm, dl.so is updated?

-- 
eban