I find myself wanting to pass a method as the block to another method on a
fairly regular basis, and I don't really like how the code turns out.
Currently it looks like this:

	result.addFaultListener(self, &(method(:addFault).to_proc))

which just doesn't seem like it makes the intent very clear (and it's not
very memorable for the next time I want to do it). I guess I could do
something like:

	result.addFaultListener(self) {
		| fault |
		addFault(fault)
	}

but I don't like that any better (a lot of typing and I have to pass through
all the arguments). Is there a better way to do this? Does anyone else find
themselves doing it, and if so, should there be an easier way to do it, or
do you consider one of the above options to be sufficient? Of course,
there's also the possibility that passing a method as the block for another
method isn't "Ruby"; I'm something of a nuby, so I'll also ask, is it bad
(Ruby) design to pass a method as the block to a method?

Thanks,


Nathaniel

<:((><
+ - -						+ - -
| RoleModel Software, Inc. &		| EQUIP VI
| The XP Software Studio(TM)		|