"Kurt M. Dresner" wrote:
> 
> > I recommend upgrading your gcc to 3.2 or later.  There are several
> > solaris-specific improvements.  I haven't had this problem with gcc 3.1 or
> > later.  Of course, I still have the large file issue, but that's another
> > story.
> 
> Unfortunately, I'm not in charge of the machine in question. :o(
> 
> What is the large file issue?
> 
> -Kurt

I first mentioned this issue in ruby-talk 67160, and subsequently (with
no resolution) brought it up again in 77026.  The issue for me
personally stems from procfs.h and one of my extensions.  This is the
relavent code from sys/procfs.h:

#if !defined(_LP64) && _FILE_OFFSET_BITS == 64
#error  "Cannot use procfs in the large file compilation environment"
#endif

Somehow _LP64 is not being defined during the configure stage for 1.8. 
I don't have this problem with 1.6.x.  I haven't been able to narrow
this one down.  The only way I can get around this is to build with the
--disable-largefile option.

I also haven't had any luck building Ruby with the -m64 or -mcpu
options.  Not that I need to or anything - I just like messing around.
;)

Regards,

Dan