--
JRAynaQAFhPez0VXRll Content-Type: text/plain Content-Transfer-Encoding: quoted-printable On Llu, 2003-08-25 at 14:36, Jim Freeze wrote: > On Monday, 25 August 2003 at 21:35:54 +0900, Keith Willoughby wrote: > > On Llu, 2003-08-25 at 13:17, Jim Freeze wrote: > > > While trying to install the stable version of Ruby > > > I get the following messsage when running autoconf: > > > > > > autoconf > > > Autoconf requires GNU m4 1.1 or later > > > > > > What is m4? > > > > > > uname -a > > > SunOS juno 5.8 Generic_108528-19 sun4u sparc SUNW,Ultra-5_10 > > > > It's the Gnu macro processor (autoconf makes heavy use of macros) > > > > Can you give me a URL to download the macros. > I can't seem to find them on the gnu site. > (I've found docs and text files, but no macros.) It's the actual processor, rather than the macros. http://savannah.gnu.org/projects/m4/ ftp://ftp.gnu.org/pub/gnu/m4 Going back to the beginning, though - are you sure you need to run autoconf? Shouldn't ./configure && make be enough? Or are you building it from CVS or something? -- Keith --
JRAynaQAFhPez0VXRll Content-Type: application/pgp-signature; name=signature.asc Content-Description: This is a digitally signed message part -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.2 (GNU/Linux) iD8DBQA/ShQ3tq7tV7GUrjURAvIeAKCs8FDkj7zd32YuDPbpFkr+FVo6CACeKk5Y hNHN1z9c9w6MVurxClkMFSs3E -----END PGP SIGNATURE----- --
JRAynaQAFhPez0VXRll--