Hi, rubyists.


I am getting an error when I try to use telnet under 1.8.0 (it was 
working fine under 1.6.8 and 1.7.3).

(mark-1)-> tn.rb
/devtools/shasta/lib/ruby/1.8/net/telnet.rb:164:in `require': No such 
file to load -- socket (LoadError)
        from /devtools/shasta/lib/ruby/1.8/net/telnet.rb:164
        from tn.rb:2:in `require'
        from tn.rb:2

(zcars0u3)-> cat tn.rb 
#! /devtools/shasta/bin/ruby
require 'net/telnet'

(zcars0u3)-> /devtools/shasta/bin/ruby -v
ruby 1.8.0 (2003-08-04) [sparc-solaris2.8]

Any ideas?

-- 
-mark.

All opinions expressed are my own and do not
reflect in any way those of Nortel Networks.