Saluton!

Implementing some additional mathematical functions I came across
acosh, asinh, and atanh. Here the Principle of Least Surprise runs
into a severe problem.

On the one hand it is not that uncommon to use these names. On the
other hand mathematicians prefer to call them arcosh, arsinh and
atanh.

What about allowing for *both* names in later versions of Ruby?

Several names for one method are not that uncommon in Ruby. For a
hash h the follwing methods are identical:

h.key?
h.has_key?
h.include?
h.member?

Gis,

Josef 'Jupp' Schugt
-- 
N'attribuez jamais ? la malice ce que l'incomp?tence explique !
-- Napol?on