--AhhlLboLdkugWU4S
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

This patch just removes the '$defout is obslete' [sic] warning from the fcgi
library when run under 1.8.0

Cheers,

Brian.

--AhhlLboLdkugWU4S
Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment; filename=ruby-fcgi-patch

diff -uNr ruby-fcgi-0.8.3.orig/README ruby-fcgi-0.8.3/README
--- ruby-fcgi-0.8.3.orig/README	Tue Mar 25 15:49:46 2003
+++ ruby-fcgi-0.8.3/README	Thu Aug 14 15:24:29 2003
@@ -14,7 +14,7 @@
 
   $ ruby install.rb config
     (Pure Ruby Version: ruby install.rb config --without-ext)
-    (Some systems need: ruby install.rb config --with-fcgi-includesr/local/include --with-fcgi-libsr/local/lib)
+    (Some systems need: ruby install.rb config -- --with-fcgi-includesr/local/include --with-fcgi-libsr/local/lib)
   $ ruby install.rb setup
   # ruby install.rb install
 
diff -uNr ruby-fcgi-0.8.3.orig/lib/fcgi.rb ruby-fcgi-0.8.3/lib/fcgi.rb
--- ruby-fcgi-0.8.3.orig/lib/fcgi.rb	Tue Mar 25 15:49:46 2003
+++ ruby-fcgi-0.8.3/lib/fcgi.rb	Thu Aug 14 15:24:21 2003
@@ -468,15 +468,15 @@
     else
       exit_requested  alse
       trap('SIGPIPE','IGNORE')
-      o_stdout, o_defout, o_stderr  stdout, $defout, $stderr
+      o_stdout, o_stderr  stdout, $stderr
 
       FCGI::each {|request|
         trap('SIGUSR1') { exit_requested  rue }
-        $stdout, $defout, $stderr  equest.out, request.out, request.err
+        $stdout, $stderr  equest.out, request.err
 
         yield CGI.new(request, *args)
         
-        $stdout, $defout, $stderr  _stdout, o_defout, o_stderr
+        $stdout, $stderr  _stdout, o_stderr
         request.finish
         trap('SIGUSR1','DEFAULT')
         raise SignalException, 'SIGUSR1' if exit_requested

--AhhlLboLdkugWU4S--