> The Ruby MySQL Interface 2.4.4a package compiles fine with Ruby 1.8.0 
> on the OS X 10.2.6 I'm running, but as soon as I try to run the test 
> script (or require 'mysql' in IRB), it cramps with this:

It appears that this problem only occurs if the Ruby MySQL Interface is 
compiled with 1.8. Luckily, you can use a version of Ruby MySQL 
Interface compiled with 1.6.8 along with 1.8. So that solves the 
problem. Temporarily, at least.

/ David