Today's release (0.1.2) runs fine in Ruby 1.8.0 without any warnings.

Francis