Brad wrote:

>All:
>
>Has anyone else run into Rockit installation problems using Ruby 1.8.0?
>
>Aside from getting a plethora of warnings concerning deprecated API calls
>which I've managed to fix via simple text substitution), ruby encountered a
>segmentation fault and died; however, the script finished running and
>pretended to install the 'executable'.
>
>  
>

I didn't have any issues with seg faults.  I'm running on Windows XP and 
compiled my own ruby-1.8.0 with Visual C++.  I fixed all the same 
"Object.type is deprecated" warnings and got stuck trying to bootstrap 
the parser generator, which looks more like a Rockit bug than a Ruby one:
<snip>
 (0.11 s 86.24%)
Parsing rockit-grammar.grammar./glr_parser.rb:106:in 
`handle_parse_error': No va
lid token found on stacks: (ParseException)
stack 0: on line:
  ' Grammar for rockit grammars, version 0.5.1'
  ^
</snip>

Mr. Feldt, any ideas on this one?

Thanks,
Chad