I'm getting the following warnings with the 1.8.0-preview5 from OpenSSL:

 sswa/bin/ssltest:7: warning: instance variable @cert_store not initialized
 sswa/bin/ssltest:7: warning: instance variable @cert not initialized
 sswa/bin/ssltest:7: warning: instance variable @key not initialized
 sswa/bin/ssltest:7: warning: instance variable @client_ca not initialized
 sswa/bin/ssltest:7: warning: instance variable @ca_file not initialized
 sswa/bin/ssltest:7: warning: instance variable @ca_path not initialized
 sswa/bin/ssltest:7: warning: instance variable @verify_mode not initialized
 sswa/bin/ssltest:7: warning: instance variable @timeout not initialized
 sswa/bin/ssltest:7: warning: instance variable @verify_depth not initialized
 sswa/bin/ssltest:7: warning: instance variable @options not initialized

with the following test program:
---
#!/usr/local/bin/ruby -w

require "socket"
require "openssl"

s1 = TCPSocket.new('localhost', 'imap')
s2 = OpenSSL::SSL::SSLSocket.new(s1)
---

Not a showstopper, of course.

1.8.0 looks really fabulous, and is working great for me.

Special thanks to all the Ruby contributors for saving me from
mod_perl this month (Yea!!!), and for a splendid language in general.

d.k.

-- 
Daniel Kelley - San Jose, CA
For email, replace the first dot in the domain with an at.