Hi,

In message "Re: Warning error in YAML"
    on 03/06/27, Jason Creighton <androflux / softhome.net.remove.to.reply> writes:

|Personally, I think Object::Hash, Kernel::Hash are silly, and ::Hash is ugly.
|Why not just say "Hash"?

Sometimes you have to stand ugliness, when Hash may be overridden.

  class Foo
    Hash = {}
    def foo
      p Hash
      p ::Hash
    end
  end
  Foo.new.foo

  => {}
     Hash
-- 
							matz.