Hi,

In message "Re: ruby 1.8.0-preview3 build errors"
    on 03/06/25, Aredridel <aredridel / nbtsc.org> writes:

|> Show me your "rbconfig.rb" file.

Thank you.

|  CONFIG["configure_args"] = "'LDFLAGS=-s' 'CFLAGS=-O2 -march=athlon ' '' '' 'CXXFLAGS=-O2 -march=athlon ' '' '' 'FFLAGS=-O2 -march=athlon ' '' '' 'CPPFLAGS=' 'CC=i686-pld-linux-gcc' 'CXX=i686-pld-linux-g++' '--build=athlon-pld-linux' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/lib' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--enable-shared' 'build_alias=athlon-pld-linux' 'host_alias=' 'target_alias='"

This is a line that caused a problem.  Somehow you've specified "" to
your configure arguments.

                                                          matz.

--- lib/mkmf.rb	16 Jun 2003 07:14:41 -0000	1.131
+++ lib/mkmf.rb	25 Jun 2003 04:09:42 -0000
@@ -19,2 +19,3 @@
     arg, val = arg.split('=', 2)
+    next unless arg
     if arg.sub!(/^(?!--)/, '--')
@@ -28,2 +29,3 @@
     arg, val = arg.split('=', 2)
+    next unless arg
     if arg.sub!(/^(?!--)/, '--')