>    "tmp" is always a temporary variable.

There's almost never any point in using any name containing "tmp". Most
variables are temporary...

I prefer using "aux" if I need an ad-hoc variable and cannot come up with a
better name.

Cheers
Franz

"Daniel Carrera" <dcarrera / math.umd.edu> schrieb im Newsbeitrag
news:20030615171156.GD2560 / math.umd.edu...
> On Mon, Jun 16, 2003 at 01:57:50AM +0900, John Johnson wrote:
>
> > Also, the reason it is hWnd instead of something more verbose, is you
have
> > to type it over and over and over when writing Windows programs
>
> I guess that it might be an indiosyncratic term that a Windows programmer
> would "just know".  The rest of the programming world also has those:
>
>    "tmp" is always a temporary variable.
>    i,j are always integer indices.
>
> >
> > Having said all that, I much prefer The Ruby Way.
>
> Definitelly.  I still really dislike the Hungarian notation.  I can think
> of examples where it would really take away legibility.  Specially with
> Ruby.
>
> --
> Daniel Carrera         | OpenPGP fingerprint:
> Graduate TA, Math Dept | 6643 8C8B 3522 66CB D16C D779 2FDD 7DAC 9AF7 7A88
> UMD  (301) 405-5137    | http://www.math.umd.edu/~dcarrera/pgp.html
>