I was trying out the example from PickAxe (Pg. 529) which does: require
"irb/xmp"

I get the following error:

C:/ruby/lib/ruby/1.6/irb/xmp.rb:13:in `require': No such file to load --
irb/irb (LoadError)
 from C:/ruby/lib/ruby/1.6/irb/xmp.rb:13
 from C:\atest\tst_xmp.rb:1:in `require'
 from C:\atest\tst_xmp.rb:1

And sure enough, when I checked in [C:/ruby/lib/ruby/1.6/irb] there is no
irb.rb

I am using Andy's one-click windows installer for (ruby 1.6.8 (2002-12-24)
[i586-mswin32]).
Have I missed something ?

-- shanko