On Thu, Apr 17, 2003 at 05:20:23PM +0900, Cedric Foll wrote:
> > [Assuming you meant (1)]
> 
> Yes i was that.
> I've tried to build the freeride package.
> 
> > 
> > It will only generate the file you got, but it depends on several other
> > packages you'd have to rebuild too:
> > 	apt-get -b source libfox1.0
> > 	dpkg -i libfox1.0*deb # installs doc, dev, dbg packages too
> > 	apt-get -b source libfxscintilla1
> > 	dpkg -i libfxscintilla*deb # install -dev too
> > 	apt-get -b source libripper-ruby
> > 	dpkg -i libripper-ruby*deb
> > ..etc...
> 
> Which source package provides freeride1.6-base ? It's my problem, this package is
> required to install freeride1.6 after the build but I don't have it.

Hehe, it's just a package generated with equivs, it's got no source :-)
All it does is depend on the required packages:

Package: freeride-base1.6
Status: install ok installed
Priority: optional
Section: misc
Installed-Size: 36
Maintainer: Mauricio FernŠŌdez <batsman.geo / yahoo.com>
Version: 1.0
Provides: freeride-base
Depends: ruby, libripper-ruby (>= 0.0.5-1), libfox-ruby (>= 1.0.16-1)

> I have a testing distrib and freeride can't be installed with a 'apt-get
> install' because of a dependance pb with libfox. If i install the new
> version of libfox (ie 1.0.29 instead of 1.0.18) I break to much dependances.

That's kind of a problem, because FreeRIDE needs (quoting from 
http://www.rubyide.org/cgi-bin/wiki.pl?UserDoc)

[FOX], a cross-platform C/C++ GUI Toolkit that is now gaining a wide
acceptance in the Ruby community (version 1.0.x with x > 26) 
[FXRuby], the ruby interface to the FOX library (version 1.0.16 or
above, but do not use 1.0.17) 
[FXScintilla], a FOX port of the [Scintilla] widget editor (version
1.49.0 or above) 

That's why I packaged libfox1.0 1.0.36-1 .

> It's why i'm trying to build the package (I regulary do this in order to
> install a package of the 'unstable' distrib when it can't be done because of
> pb of dependances, after a build of the package it's ok)
 
I am working on the packages and will soon upload them to
ftp.rubyide.org .

I have tested that it is possible to rebuild all the packages with
simply
	apt-build install freeride
Note however that in your case you'd have to hack the freeride package
to alter the "Depends" line, as it isn't automatically generated.
I don't think you'd be able to run FreeRIDE, however (for the reason
given above).

Could you tell me what dependencies would be broken by switching to
a new libfox1.0? Could you perhaps upgrade to my libfox1.0 package,
install -dev too and then rebuild them?

-- 
 _           _                             
| |__   __ _| |_ ___ _ __ ___   __ _ _ __  
| '_ \ / _` | __/ __| '_ ` _ \ / _` | '_ \ 
| |_) | (_| | |_\__ \ | | | | | (_| | | | |
|_.__/ \__,_|\__|___/_| |_| |_|\__,_|_| |_|
	Running Debian GNU/Linux Sid (unstable)
batsman dot geo at yahoo dot com

<igor> Hah! we have 2 Johnie Ingrams in the channel :)
<igor> Hey all btw :)