This has nothing to do with gentoo.  I see the same behavior on Debian, Red 
Hat, and Slackware.

On Sunday 02 March 2003 10:50 am, Child wrote:
> On Mon, 3 Mar 2003 01:46:36 +0900, ts wrote:
> >>> I can't show the offending code, because the app has about 5000 lines
> >>> of code and until now the bug appeared in several places.
> >
> >  If it's easy to reproduce the bug send me, in private email, the source.
>
> It should be easy - I'll send it to you later today.
>
> >>> I had the same problem with Ruby 1.6.8. I run Ruby on Gentoo Linux.
> >
> >  Personnaly I don't trust linux distribution : debian was able to
> >  *completely break* Berkeley DB 4.0.14 :-(((
>
> Gentoo is the "source" distribution - everything is compiled on my
> machine. All the distro provides is an .ebuild file containing rules for
> downloading, unpacking and compiling the package. And for Ruby 1.8.0 I
> created that file myself - it contains nothing more than simple
> ../configure; make; make install;
>
> Conclusion: although I agree some binary packages in sme distributions
> are broken, I am sure this is not such case.

-- 
Seth Kurtzberg
M. I. S. Corp.
480-661-1849
seth / cql.com