Hi,

I was just about to leave when Robert Feldt wrote:

# I've been posing dumb question on ruby-talk for so long now that

now it's my turn.  In particular, for readability, could this:

# b = BitVector.new(100000).randomize      # 1e5 random bits
# a = BitVector.new(100000).randomize      # another 1e5 random bits

be replaced by this:

b = BitVector.new(100_000).randomize      # 1e5 random bits
a = BitVector.new(100_000).randomize      # another 1e5 random bits

since ruby -e 'print 100_000, "\n"' produces 100000?

If every bit of progress helps, then with BitVector, Ruby's success is now 
assured. :-)

Conrad Schneiker
(This note is unofficial and subject to improvement without notice.)