Conrad:
> > nilDefault or nil_default?

Charles:
> I really prefer avoiding underscores in names.  Internal 
> capitalization provides all the break needed for easy 
> reading, and many auxiliary programs split the parts 
> of an underscored name separately.

Let's not start a war from this, but I'd like to make few notes:

1) Ruby standard library uses underscore pretty much consistently
   on method names (which means I didn't find any counter 
   example fast), and UpcaseStartingCamelCase on ClassNames. 
   Stuff at lib/ might not be so consistent anymore.

2) It has been said (can't site any authority here) that non-native
   English speakers find under_scored names easier to read than other
   alternatives (like popular camelCase).

3) For me both go. I think Ruby code is cleaner with modest use of
   underscores, but excessive use of them makes the code hard to read.
   The same applies to camelCase.

I guess I like things like they are now, and would vote for conservatism on
this one. Meaning nil_default is ok. (I guess we ended up naming the method
as when, and the problem went away naturally. :)

	- Aleksi