Hi Lyle,

In article <v3ba374s0vje6b / corp.supernews.com>,
	Lyle Johnson <lyle / users.sourceforge.net> writes:
> All,
> 
> The latest release of FXRuby is now available for download:
> 
> http://sourceforge.net/project/showfiles.php?group_id=20243&release_id=136352


I installed ruby

$ ruby -v
ruby 1.8.0 (2003-01-23) [i686-linux]

and after that fox-1.0.30 and then FXRuby-1.0.18:
$ ruby install.rb config -- \
       --with-fox-include=/home/martin/Ruby/include/fox \
       --with-fox-lib=/home/martin/Ruby/lib
install.rb: entering config phase...
---> lib
---> lib/fox
<--- lib/fox
<--- lib
---> ext
---> ext/fox
/home/martin/Ruby/bin/ruby /home/martin/FXRuby-1.0.18/ext/fox/extconf.rb \
       --with-fox-include=/home/martin/Ruby/include/fox \
       --with-fox-lib=/home/martin/Ruby/lib
install.rb:397: warning: Insecure world writable dir /home/martin/Ruby/bin,
        mode 040777
checking for sys/time.h... yes
checking for signal.h... yes
checking for png_create_read_struct() in -lpng... yes
checking for deflate() in -lz... yes
checking for jpeg_mem_init() in -ljpeg... yes
checking for TIFFSetErrorHandler() in -ltiff... yes
checking for XShmQueryVersion() in -lXext... yes
checking for XFindContext() in -lX11... yes
checking for glXCreateContext() in -lGL... yes
checking for gluNewQuadric() in -lGLU... no
creating Makefile
---> ext/fox/include
<--- ext/fox/include
<--- ext/fox
<--- ext
install.rb: config done.

$ ruby install.rb setup
$ ruby install.rb install

$ irb
irb(main):001:0> require 'fox'
LoadError: No such file to load -- opengl
    from /home/martin/Ruby/lib/ruby/site_ruby/1.8/fox/glgroup.rb:2:in `require'
    from /home/martin/Ruby/lib/ruby/site_ruby/1.8/fox/glgroup.rb:2

Any suggestions?

Thanks for any hints in advance,
Martin.