Hi,
thanks for the effort ...
What exactly am I supposed to do with the patch? Running it gives the 
following message:

C:\DOCUME~1\longwitz\LOCALS~1\Temp\rb57.tmp:1: parse error
--- ../TkGnuplot.old/gnuplot.rb	Thu Oct  3 10:52:39 2002
       ^
Completed(1)

So I replaced all the lines "+" for "-" in gnuplot.rb, but found that I 
don't have 'win32_popen' ... installed after a quick Google search ...

Now I get this:
C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:105:in `write': Invalid 
argument (Errno::EINVAL)
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:105:in `_send_cmd'
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:96:in `synchronize'
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:96:in `_send_cmd'
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:154:in `cmd'
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:184:in `set'
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:88:in `method_missing'
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:420
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:419:in `synchronize'
	from C:\Program Files\ruby\tkgnuplot\gnuplotP.rb:419
Completed(1)

???

Cheers, Ralf


nagai / ai.kyutech.ac.jp wrote:
> Hi, 
> 
> From: ptkwt / shell1.aracnet.com (Phil Tomson)
> Subject: Re: tkgnuplot problem: fork() on win (popen3 for windows?)
> Date: Tue, 28 Jan 2003 14:40:20 +0900
> Message-ID: <b152lh0kc4 / enews2.newsguy.com>
> 
>>Didn't someone recently announce that they implemented popen3 for Windows?
> 
> 
> Thank you for your information. 
> Well, Ralf, could you try the following patch?
> Because I have no environment to test it.
> 
> --- ../TkGnuplot.old/gnuplot.rb	Thu Oct  3 10:52:39 2002
> +++ ./gnuplot.rb	Wed Jan 29 11:57:49 2003
> @@ -2,12 +2,50 @@
>  #
....