Matz writes:

# In message "[ruby-talk:6111] Re: detect:ifNone: in Ruby"
#     on 00/11/07, Hugh Sasse Staff Elec Eng <hgs / dmu.ac.uk> writes:
# 
# |> How about default, defaults or defaulting (I like the last).
# |
# |I'd call it "nilGives" or "nil_gives", etc.  I think default leaves too
# |much open -- it depends on how your objects are made as to what their
# |defualt value is.
# 
# I agree with that `default' is too broad.  And both `nilGives' (case
# mixture; third person) and 'nil_gives (third person) are not Rubyish
# neither.

nilDefault or nil_default?

Conrad Schneiker
(This note is unofficial and subject to improvement without notice.)